Установка аудиоплеера Qmmp в Ubuntu.

В данной статье пойдет речь о замечательном аудиоплеере Qmmp для Ubuntu, интерфейс которого схож с таким легендарным плеером, как Winamp.

Коротко о аудиоплеере Qmmp.

Данная программа является аудиоплеером, написанным с использованием библиотеки Qt. Программа имеет интерфейс, аналогичный winamp или xmms.

Поддерживает огромное количество аудиоформатов:

  • MPEG1 layer 2/3
  • Ogg Vorbis
  • Ogg Opus
  • Native FLAC/Ogg FLAC
  • Musepack
  • WavePack
  • трекерные форматы (mod, s3m, it, xm и т.д.)
  • ADTS AAC
  • CD Audio
  • WMA, Monkey's Audio (и др. форматы библиотеки FFmpeg)
  • PCM WAVE (и др. форматы библиотеки libsndfile)
  • midi
  • SID
  • форматы звука игровых консолей (AY, GBS, GYM, HES, KSS, NSF, NSFE, SAP, SPC, VGM, VGZ, VTX)

И имеет настраиваемый интерфейс, поддерживает обложки XMMS и Winamp 2.x. Вот, например, с обложкой Winamp:

А вот ещё некоторые выборочные обложки:

В настройках доступны для выбора огромное количество модулей (плагинов), с помощью которых можно расширить стандартный функционал аудиоплеера:

Установка аудиоплеера Qmmp в Ubuntu.

Чтобы установить самую последнюю версию аудиоплеера Qmmp в Ubuntu, откройте терминал и выполните следующие команды.

Добавляем репозиторий приложения и обновляем сведения о пакетах в репозиториях:

sudo add-apt-repository ppa:forkotov02/ppa
sudo apt update

Для установки самой современной версии Qmmp на QT5, выполните следующую команду в терминале:

sudo apt install qmmp qmmp-plugin-pack

Для пользователей Ubuntu выше 16.04 есть версия плеера Qmmp на QT4, её можно установить, выполнив следующую команду в терминале:

sudo apt install qmmp-qt4 qmmp-plugin-pack-qt4

Всё, аудиоплеер Qmmp установлен в Ubuntu. Можно наслаждаться вашей любимой музыкой.

Удаление аудиоплеера Qmmp из Ubuntu.

Чтобы удалить аудиоплеер Qmmp из Ubuntu, откройте терминал и выполните следующие команды:

sudo add-apt-repository --remove ppa:forkotov02/ppa
sudo apt update

Если ставили qt4 версию, то выполняем следующую команду удаления:

sudo apt remove qmmp-qt4 qmmp-plugin-pack-qt4

Если ставили обычную версию, то выполняем следующую команду удаления:

sudo apt remove qmmp qmmp-plugin-pack

Настройка аудиоплеера Qmmp в Ubuntu.

Как добавить обложки в Qmmp.

В стандартной поставке идёт только одна обложка. Естественно, что вы можете вообще использовать любые winamp 2.x обложки. Но автор данного плеера подготовил целый архив обложек, который можете скачать по следующей ссылке:

http://qmmp.ylsoftware.com/files/skins/Skins_All_in_One.zip

Скачайте архив и распакуйте его в каталог:

~/.qmmp/skins

После чего, в Настройках плеера (ctrl - P) на вкладке Внешний вид - Обложки жмёте клавишу "Обновить" можете выбирать обложки:

Как добавить иконку приложения на главную панель.

Выглядит это следующим образом:

В Настройках (ctrl - P) на вкладке Модули в разделе "Общие" включаем "Модуль Status Icon". А если нажать правой кнопкой мыши по модулю, то можно перейти в его настройки. И проставить галочку "Использовать стандартные иконки": 

Тогда иконка на панели более симпатичная и не выбивается из общего стиля.

Как показывать уведомление о проигрываемом треке.

В модулях еще можно настроить уведомление о треке, который начал воспроизводится:

В модулях задействуем: ''Модуль уведомлений":

В его настройках (правой кнопкой мыши на модуле - настройки) можно выбрать положение, прозрачной и время отображение:

Также, если ставили модуль Status Icon, то советую в его настройках убрать Всплывающее сообщение и подсказку, чтобы не дублировался функционал уведомлений:

Qmmp слишком мелкий, я ничего не вижу, как его сделать больше?

Ничего сложного нет, в Меню - Вид выбираем "Двойной размер":

Вызов меню происходит по нажатию в самый крайний верхний левый угол.

В результате, было:

Стало:

Вот и всё.

  • https://plus.google.com/+AlexanderBakumenko Alexander Bakumenko

    Ошибочная информация в статье. Плеер qmmp на QT5, то есть это более современная версия, чем qmmp-qt4

    • Edward Kobylyanets

      Спасибо за замечание, в статье исправил.
      На официальном сайте меня изначально смутила надпись, что qt4 доступна для пользователей 16.04 и выше.