Установка Legacy драйверов на видеокарты AMD Radeon в Ubuntu

Обновил статью, залил файл с драйверами. Теперь должно работать скачивание по ссылке в статье.

Я обновил статью, так как второй способ не работает, судя по отзывам.

Кроме того, очень важное замечание - данная версия драйверов пропатчена только для работы на версии ядра Linux до 3.8 (включительно).

Всегда существовали проблемы с драйверами ATI для Linux.
На старые видеокарты компания AMD перестала поддерживать драйвера для linux.
На такие видеокарты как AMD Radeon HD 4000, AMD Radeon HD 3000, and AMD Radeon HD 2000 Series.

И в это статье я расскажу о нескольких способов установки Legacy драйверов AMD в ubuntu.


В этой статье пойдет речь об установке драйверов на следующие устройства:

AMD Radeon HD 4000 Series
AMD Radeon HD 3000 Series
AMD Radeon HD 2000 Series
AMD Radeon HD Series AGP
AMD Mobility Radeon HD 4000 Series
AMD Mobility Radeon HD 3000 Series
AMD Mobility Radeon HD 2000 Series

Пройдя на официальный сайт драйверов AMD для Linux:

можно убедиться, что:

Description:

Automated installer and Display Drivers for Xorg 6.9 to Xserver 1.12 and Kernel version up to 3.4

 То есть, эти драйвера работают на версии ядра Линукс до 3.4 и Xserver до 1.12.

Начиная с Ubuntu 12.04 Xserver от 1.13 и версия ядра от 3.5.

Поэтому я хочу поделиться способом, как можно установить эти драйвера в Ubuntu 12.04.

Как я писал выше, данные драйвера работают только на версиях ядра Linux до 3.8, то возможно установить и на 13.04, но придется делать понижение версии ядра Linux.

Вот скриншоты работоспособности драйвером на Ubuntu 12.04:

Собственно моя видеокарта:

Amd Catalyst Control Center:

И шестеренки:

Установка legacy драйверов AMD Radeon в Ubuntu 12.04

Еще раз повторюсь, не пробуйте устанавливать данные драйвера на системе с версией ядра Linux больше, чем 3.8!
Этот способ представляет собой действия понижения версии Xserver до версии 1.12 и установки пропатченных драйвером AMD для ядер Линукса до версии 3.8.

Сначало сделаем "даунгрейд" (понизим версию) Xserver до версии 1.12.

Для этого откроем терминал и выполним следующие команды:

sudo add-apt-repository ppa:makson96/fglrx

sudo apt-get update

sudo apt-get upgrade

В этом репозитории есть драйвера для видеокарт. Но не ставьте их отсюда. Они работают плохо, и после установки вы поймает экран без панелей Unity. Мы его используем только для понижения версии Xserver.

Далее очень важно установить linux-headers-generic , выполняем в терминале следующую команду:

sudo apt-get install linux-headers-generic

Затем скачиваем пропатченные драйвера:

Затем запускаем команду, для просмотра информации о ядре Линукс в системе:

uname -r

Вот здесь очень важно!
Смотрим на то, что вывело в консоль.
У меня это было:

3.5.0-34-generic

Нам нужно создать папку: /usr/lib/modules/3.5.0-34-generic/build
Естественно, что нужно заменить  "3.5.0-34-generic" на то, какую версию ядра у вас вывело в консоле.

Это можно сделать в наутилусе, открыв его от администратора, либо выполнив следующие команды в консоле:

sudo mkdir /usr/lib/modules/3.5.0-34-generic/

sudo mkdir /usr/lib/modules/3.5.0-34-generic/build

Теперь копируем версию generic в нашу созданную папку, выполните в терминале следующую команду (это одна строчка):

sudo cp /usr/src/linux-headers-3.5.0-34-generic/include/linux/version.h /usr/lib/modules/3.5.0-34-generic/build

Естественно, что нужно заменить  "3.5.0-34-generic" на то, какую версию ядра у вас вывело в консоле.

Теперь переходим в папку, в которую мы распаковали архив с пропатченными драйверами. В архиве папка называется amd. Вот в нее нужно зайти через терминал. Для перехода по папка используется команда cd.
Я распаковал в домашний каталог:

cd amd/

И запускаем установку драйверов командой:

sudo ./ati-installer.sh 8.97.100.7 –install

Ждем окончания установки.

После того, как драйвера установились.
Выполняем в терминале команду:

sudo amdconfig –initial

Теперь можно перезагрузить компьютер.
Заходим в консоль и выполняем команду:

fglrxinfo

Если будет выведено примерно вот такое:

OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 4300/4500 Series     
OpenGL version string: 3.3.11672 Compatibility Profile Context

Значит драйвер установился и работает. И напоследок, удалим репозиторий из системы, чтобы наш Xserver оставался 1.12 и не обновлялся:

sudo add-apt-repository --remove ppa:makson96/fglrx

Всё. Наслаждайтесь.

Удаление драйверов ATI.

//

Откройте терминал и выполните следующие команды, которые удалят драйвера ati из системы:

sudo sh /usr/share/ati/fglrx-uninstall.sh

sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx

  • Анонимный

    Спасибо!

  • https://www.blogger.com/profile/00702307566779583264 Snop Miner

    У меня версия обновилась до 3.8.0-25-generic так вот по указонному пути нет файла version.h но я нашел его в другом месте в том же 3.8.0-25-generic, надеюсь прокатит! Аминь!!!

  • https://www.blogger.com/profile/00702307566779583264 Snop Miner

    Итак ураааа все получилось, немного помучился с этим version.h но в конце концов все встало без проблем!

    • https://www.blogger.com/profile/00865845114198842309 Администратор

      Поздравляю. Молодец, что не делали абсолютно все копируя :). Я делал эти все манипуляции на 12.04. Возможно в этой же папке, но немного в другом месте лежит version.h . Обязательно посмотрю на 13.04, где более новое ядро. Спасибо, что сказали.

  • https://www.blogger.com/profile/16475499053812077266 mihrjuk

    Не удалось найти пакет fglrx-installer
    Что за ерунда?

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Не знаю, что случилось с репозиторием. Драйвера можно скачать отсюда из этого репозитория выберите для вашей системы деб пакеты:
      https://launchpad.net/~xorg-edgers/+archive/ppa/+packages

    • https://www.blogger.com/profile/16475499053812077266 mihrjuk

      спасибо, а не подскажите , какие надо пакеты на 13.04?

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Какая видеокарта? Какой дистрибутив?

  • https://www.blogger.com/profile/16475499053812077266 mihrjuk

    да и первый способ не работает на Минт 15, не снижается версия xorg.

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      На Ubuntu 12.04 и Ubuntu 13.04 работает. Протестировано.
      На Mint не проверял, не знаю.

  • https://www.blogger.com/profile/14609377134307835858 netwalker

    Здравствуйте.
    Не могу понять в чем причина — дошел до
    sudo cp /usr/src/linux-headers-3.10.1-031001-generic/include/linux/version.h /usr/lib/modules/3.10.1-031001-generic/build
    при вводе команды вываливается ошибка "cp: не удалось выполнить stat для «/usr/src/linux-headers-3.10.1-031001-generic/include/linux/version.h»: Нет такого файла или каталога"
    Подскажите пожалуйста, в чем дело.
    Спасибо

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      посмотрите точно, где находится version.h

      Вот этот параметр замените на свой.
      /usr/src/linux-headers-3.10.1-031001-generic/include/linux/version.h

      Я описывал для своего ядра.

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      И путь до version.h пропишите свой. Здесь просто консоль ругается, что не находит этот путь.

      команда cp — копирует файл из одного пути в другой.

  • https://www.blogger.com/profile/14609377134307835858 netwalker

    Ubuntu 13.04

  • https://www.blogger.com/profile/14609377134307835858 netwalker

    Спасибо большое.
    Не могли бы Вы мне помочь еще раз, если это возможно.
    На компьютере стоит Ubuntu 13.04 x64, видеокарта — ATI Radeon 4870×2, хочу попробовать еще установку драйверов по второму способу.
    Дошел до ввода команды sudo apt-get install fglrx-installer, и получил ошибку — "Не удалось найти пакет fglrx-installer", выше Вы писали, что можно скачать драйвера из репозитория https://launchpad.net/~xorg-edgers/+archive/ppa/+packages.
    Не могли бы Вы подсказать, какие конкретно .deb пакеты нужно скачать для моей связки?
    Заранее большое спасибо.

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Честно из того ppa не пробовал ставить дрова, можно сломать систему, unity не загрузиться. Как альтернатива есть вот такой репозиторий. Хотя жалобы есть. Работающий способ тот, что в статье под номером 1. Лучше минут на 10 дольше посидеть, поустанавливать дрова, чем потом мучаться с их удалениям после установки из репов.

      sudo add-apt-repository ppa:makson96/fglrx
      sudo apt-get update
      sudo apt-get upgrade
      sudo apt-get install fglrx-legacy

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Из того репозитория, что во втором пункте дрова не работают с xorg 1.13. Удалю его из статьи.

  • https://www.blogger.com/profile/14609377134307835858 netwalker

    При поиске version.h у меня вылезло достаточно много файлов с этим названием, файлы раскиданы по разным папкам, и если честно, я теряюсь, какой из них нужен.
    Содержимое файлов также разное.
    Именно поэтому я хотел попробовать установить по 2му способу.
    Видимо не судьба.

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Надо искать вот в этом каталоге version.h
      /usr/src/linux-headers-3.10.1-031001-generic/

      Пришлите сюда пути, где нашлись

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      В общем нужно сделать следующее:
      Создать символическую ссылку: Это одна команда:
      sudo ln -s /usr/src/linux-headers-3.10.1-031001-generic/include/generated/uapi/linux/version.h /usr/src/linux-headers-3.10.1-031001-generic/include/linux/version.h

      Далее по сценарию
      sudo cp /usr/src/linux-headers-3.10.1-031001-generic/include/linux/version.h /usr/lib/modules/3.10.1-031001-generic/build

  • https://www.blogger.com/profile/14609377134307835858 netwalker

    Хорошо, спасибо большое, вечером попробую.

  • https://www.blogger.com/profile/14609377134307835858 netwalker

    Отписываюсь.
    Драйвера в общем то поставились, но после перезагрузки — пустой экран без панелей Unity.
    В процессе установке по способу №1 столкнулся с еще одной проблемой:
    при выполнении
    sudo mkdir /usr/lib/modules/3.10.0-031001-generic/ — "mkdir: невозможно создать каталог «/usr/lib/modules/3.10.1-031001-generic/»: Нет такого файла или каталога" (посмотрел, в каталоге /usr/lib нет каталога /modules), я сделал следующее: sudo mkdir /usr/lib/modules/ затем sudo mkdir /usr/lib/modules/3.10.1-031001-generic/ затем sudo mkdir /usr/lib/modules/3.10.1-031001-generic/build далее — так, как Вы говорили.
    Может быть есть какие то мысли по этому поводу?

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Правильно всё сделали, создавали по каталогу. А в чем проблема?

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      когда нет панелей Unity, заходим либо в консоль ctr-alt-f1, либо вызываем консоль ctrl-alt-t, либо alt-f2 и пишем gnome-commander. Появится консоль: сноси все дрова, что поставили и перегружаемся. Заработает всё. По первому пункту ставьте.

    • Анонимный

      Где найти файлы, чтобы удалить?

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Какие именно?

    • Анонимный

      Драйвера, куда они устанавливаются. Потому как у меня тоже пропала панелька из-за моей невнимательности.

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      А разве это не помогает?

      sudo sh /usr/share/ati/fglrx-uninstall.sh

      sudo apt-get remove —purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx

    • Анонимный

      Нет( делал все по 1 способу

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      sudo sh /usr/share/ati/fglrx-uninstall.sh

      что выдает эта команда???

  • https://www.blogger.com/profile/14609377134307835858 netwalker

    Я так понимаю, что после удаления драйверов нужно будет выполнить заново установку по способу 1?

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Правильно.

  • https://www.blogger.com/profile/14609377134307835858 netwalker

    Добрый вечер.
    В общем попробовал, поустанавливал драйвера по способу 1 и 2.
    Ничего не получилось, к сожалению.
    После перезагрузки — нет панелей Unity.
    Не могли бы Вы сказать, как можно регулировать обороты кулера видеокарты, шум просто убивает. Может быть есть какой то софт?
    Заранее благодарю.

  • https://www.blogger.com/profile/14609377134307835858 netwalker

    На встроенном драйвере в Ubuntu 13.04

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Точно, этот пакет драйверов, пропатчили для поддержки ядра 3.8, так как официальные драйвера поддерживают только до 3.5.
      Вот с этого форума я брал драйвера: forums.debian.net/viewtopic.php?f=16&t=94847

      Хотите пользоваться драйверами ставьте убунту 12.04 🙂

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      https://launchpad.net/~makson96/+archive/fglrx
      На счет репозитория, тоже написано, что пропатченные драйвера для версии ядра до 3.8. Так что не судьбам с новыми версиями ядра поставить драйвера Legacy

  • https://www.blogger.com/profile/14609377134307835858 netwalker

    Спасибо.
    А регулировки оборотв кулера видюхи на встроенном драйвере тоже нельзя добиться? 🙁

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Дрова нужны, без не получится. То что стоят Gallium, на них не получится.
      Вообще ати конфиг может регулировать:

      aticonfig —pplib-cmd "get fanspeed 0" смотрим скорость вращения вентилятора
      aticonfig —pplib-cmd "set fanspeed 0 60" ставим скорость вращения вентилятора на 60%
      aticonfig —pplib-cmd "set fanspeed 0 auto" ставим скорость вращения вентилятора в автоматический режим
      а этой можно посмотреть температуру
      aticonfig —pplib-cmd "get temperature 0"

  • https://www.blogger.com/profile/14609377134307835858 netwalker

    Хех. Понятно, спасибо.
    То, что atoconfig умеет рулить вентилями, я в курсе.
    В общем — печалька.
    Хоть за новой видюхой беги.

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Если будете покупать, то берите nvidia. С ATI всегда были проблемы в линуксе

  • https://www.blogger.com/profile/13769602014762846817 Welzool

    Спасибо. Я только осваиваюсь. Всё сделал по первому пункту. Control centr работает. Вопрос: в сведеньях о системе пишет "Графика VESA:Y2". Так и должно быть?

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Да, не обращайте внимание, что там веса.

  • https://www.blogger.com/profile/13769602014762846817 Welzool

    Версия ОС 12.04 LTS

  • https://www.blogger.com/profile/02942246305711060745 Maikl Bary

    Спасибо. Полезная статья.

  • Анонимный

    Ребята, забудьте про Linux если у вас ATI) Вот у Nvidia драйвера сейчас очень хорошие.

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Лучше забыть про ATI видеокарты.

  • Анонимный

    напишите как сделать в ubuntu 13.04

  • Анонимный

    Дайте пожалуйста инструкцию установки драйвера ATI для старых видеокарт на ubuntu 13.04.Ситема работает пошустрей,очень не хочется возращатся на ubuntu 12.04

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Инструкция та же самая, просто нужно понизить версию ядра linux.

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-raring/

      Идем на этот сайт, выкачиваем для вашей архитектуры:
      Например для 32 бит вот эти пакеты:

      linux-headers-3.8.0-030800-generic_3.8.0-030800.201302181935_i386.deb
      linux-image-3.8.0-030800-generic_3.8.0-030800.201302181935_i386.deb
      linux-image-extra-3.8.0-030800-generic_3.8.0-030800.201302181935_i386.deb

      Скачиваем их, устанавливаем через центр приложений убунту или через dpkg -i в терминале.

      Затем перегружаемся, жмем shift при загрузке и в меню выбора ОС выбираем загрузится с другой версии ядра, выбираем с 3.8, проверяем, что всё работает. Затем удаляем ядра более высоких версий и sudo grub update. Вот и всё. Если еще нужно будет это кому-нибудь, то сделаю инструкцию в картинках.

    • Анонимный

      А почему тебе не хочется на 12.04? Как по мне так намного лучше LTS пользываться, после 13.04 мне в ней намного лучше)

    • Анонимный

      В браузерных играх которые работают через flash plaer у меня в 12.04 версии была почему-то большая нагрузка на процессор.Временами доходила до 80 процентов и больше.А на 13 -версии наблюдал нагрузку максимум 53 процента.С чем это звязано я не знаю.

  • NDR

    Так, у кого старая видюха и ось 13.04 идем сюда https://launchpad.net/~makson96/+archive/fglrx у меня карта ati hd2600 все поставилось нормуль, перезагрузился ни чего не отвалилось, все работает, скрин по ссылке
    http://i024.radikal.ru/1308/9c/e4d78cd33352.png

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Хорошо, добавлю в статью.
      Когда я поставил дрова из этого репозитория, то у меня не заработало, пришлось искать другой способ.

    • dcll

      Простите, с командами для терминала всё понятно.А с патчем что надо делать?

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      С каким патчем?

    • dcll

      Как с каким патчем?Пользователь NDR в комментариях выложыл ссылку где он якобы установил драйвер ati в ubuntu .13.04 без всяких проблем.https://launchpad.net/~makson96/+archive/fglrx
      С коммандами для терминала всё понятно но там на сайте внизу есть патч (fglrx-legacy-raring3.diff) для ядер3.8
      вот что с ним делать?

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      он имел в виду, что из этого репозитория ppa:makson96/fglrx
      поставил драйвера уже пропатченные в этом репозитории.

  • Анонимный

    Сделал всё как написано но не устанавливатся вот что пишет в терминале

    Unrecognized parameter '–install' to ati-installer.sh
    This script supports the following arguments:
    —help : print help messages
    —listpkg : print out a list of generatable packages
    —buildpkg [package] [—dryrun] : if generatable, the package will be created
    —buildandinstallpkg [package] [—dryrun] [—force] : if generatable, the package will be creadted and installed
    —install : install the driver

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      —install , заметил теперь эту ошибку в тексте.
      Вам же умный терминал выдал —install : install the driver

    • Анонимный

      Не работает ссылка на пропатченые драйвера!

  • Анонимный

    После последней команды выдало:
    amdconfig: No supported adapters detected
    Система: Xubuntu 12.04
    Видеокарта: ATI Radeon HD 3450 AGP
    Прямо беда с ней

  • Анонимный

    Что делать если реп ppa:makson96/fglrx не даунгредиn версию Xorg до 1.12 (остается 1.13), Mint 15 (Ubuntu 13.04)

    • Анонимный

      вопрос исчерпан, даунгрейдил вручную через синаптик, все работает

  • Анонимный

    Ссылка на пропатченные драйвера уже не работает((
    выложите кто-нибудь пожалуйста…

  • Анонимный

    Уважаемый автор, Edward Kobylyanets! Спасибо Вам большое за столь важную статью! Но тут люди уже указывали — ссылки на пропатченные драйвера не работают! Поэтому пришлось установить legacy драйвер из репы ppa:makson96/fglrx. Проблема решилась, но иногда система зависает намертво — подозреваю, из-за максоновских "дров".
    ПРОСЬБА — ПЕРЕЗАЛЕЙТЕ СВОИ ДРАЙВЕРА НА ФАЙЛООБМЕННИК!

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Сегодня вечером перезалью.

  • Анонимный

    Привет всем!
    У меня вопрос. А почему никто не ставит ATI драйвера, скаченные с офф. сайта?
    Я к тому, что сегодня задавался подобным вопросом, по установке ATI драйвера на убунту 13.10. Взял сегодня карту Asus AMD Radeon R7 240. После установки проприетарных драйверов, получал эмблему с надписью AMD Unsupported hardware.
    Вся проблема оказалась из за старой версии дров, которые не расщитанны на данную карту.
    Для этого, я с офф сайта: http://support.amd.com/de-de/download, скачал самые свежие драйвера, при этом выбрав точную модель карты.

    После проделал следующие шаги:
    1. Удаление старого проприетарного драйвера(если был установлен)

    Запустить терминал и ввести команду:

    cd /usr/share/ati

    далее:

    sudo sh ./fglrx-uninstall.sh

    После, необходима перезагрузка системы.

    Далее переходим на AMD Graphics Drivers. Выставляем параметры нашей карты и скачиваем в итоге предлагаемый драйвер. помещаем его в Домашняя папка.

    Открываем терминал и выполняем команду:

    unzip amd-catalyst-13.11-beta-v9.4-linux-x86.x86_64.run.zip

    После, переименовываем файл
    amd-catalyst-13.11-beta V9.4-linux-x86.x86_64.run
    на
    amd-catalyst-13.11-beta-v9.4-linux-x86.x86_64.run

    Возвращаемся в терминал и вводим команды:

    sudo chmod +x amd-catalyst-13.11-beta-v9.4-linux-x86.x86_64.run
    sudo ./amd-catalyst-13.11-beta-v9.4-linux-x86.x86_64.run

    Далее следуем предложениям установщика.
    Всё. Все работает без каких либо проблем. Возможно кому то пригодится.

    P.S. версии драйвера, замените на свои!

    • https://www.blogger.com/profile/13498300813915867195 Роман Фролов

      а зачем переименовывать? Из-за пробелов?

    • https://www.blogger.com/profile/13498300813915867195 Роман Фролов

      Asus AMD Radeon R7 240 — насколько я понимаю — это не особо старая карта (http://goo.gl/UY54iM), на ямаркете она в новинках. Речь идет о старых, уже не поддерживаемых картах. Ну… обновился хсервер, драйвер не переписали под него. Вот и парится народ.

    • https://www.blogger.com/profile/15268226576561998843 Andi

      Да переименовывать файл нужно из за пробелов, он распаковывается не совсем в правильном виде.
      ————————————————————
      А карта да, верно. Это одна из новой серии ATI карт. Я так же, почему то считал, что даже более ранние версии драйверов, можно так же скачать прямиком с офф. сайта и установить подобным образом. Меньше возни ведь в таком случае получается.

    • https://www.blogger.com/profile/13498300813915867195 Роман Фролов

      Кстати, как видяха? Завтра хочу дойти до магаза, такую же взять.

    • https://www.blogger.com/profile/15268226576561998843 Andi

      Карта вполне устраивает. Разница ощутимо заметна в играх. В некоторых бывают иногда незначительные тормоза, но я думаю, что это все же связь между линуксом и самими играми(steam).
      В магазине просил консультацию, посоветовали именно эту из тех, которые были в магазине в наличии. Кроме R9 модели.

      Сперва думал взять опять nVidia GTX 640 4 Gb RAM, но сказали, что Asus R7(которую взял) на много лучше и у ATI карт, производительность в играх выше.

      Одним словом, я не пожалел о покупке.

    • https://www.blogger.com/profile/13498300813915867195 Роман Фролов

      Спасибо. А то с тем что у меня есть (AMD Radeon HD 3000 Series) пришлось на 12.04 перейти. 3D ускорение получил, но в остальном — проприетарный драйвер свободному сливает. Набор возможных разрешений экрана адовый. Экран либо плющит, либо совсем низкое. Моргает на загрузке и само время загрузки заметно увеличилось. Реально ощутимо

  • https://www.blogger.com/profile/13498300813915867195 Роман Фролов

    а почему народ пытается поставить вместо свободных проприетарные? В чем разница и где почитать?

  • https://www.blogger.com/profile/01939002050063277908 Gena Yalovskiy

    Лично мне очень хотелось поиграть на Linux-е в Counter-Strike Source, которая без родного драйвера запускаться отказывалась (единственная, кстати; остальные игрушки работали и со свободным)! Проблема после установки предложенного автором статьи драйвера решилась, за что ему огромное спасибо!
    Видеокарта ATI Mobility Radeon HD 3470.
    Замеченные мною изменения:
    плюсы:
    1) в CSS таки уже могу играть;
    2) блок питания ноута стал намного меньше греться (и это мне не показалось, так как и батарея стала медленнее разряжаться).
    минусы:
    1) система ощутимо дольше запускается, поэтому чаще стал использовать гибернацию вместо простого выключения;
    2) с драйвером из ppa:makson96/fglrx ось иногда зависала намертво (даже комбинации Ctrl+Alt+Sys Rq+[r,e,i,s,u,b] не срабатывали!!!), после обновления ссылки на пропатченный драйвер и последующей переустановки таких зависаний пока что не наблюдаю. (Кстати, переустановка успешно прошла без копирования файла version.h в нужную директорию).

  • Анонимный

    а в 12.10 такая инструкция поможет?

    • Анонимный

      12.10 пора бы уже сносить)

  • Анонимный

    Установил , но в логе куча ERROR Check if system has the tools required for installation.
    Uninstalling any previously installed drivers.
    Unloading radeon module…
    ERROR: Module radeon is in use
    Unloading drm module…
    ERROR: Module drm is in use by radeon,ttm,drm_kms_helper
    [Message] Kernel Module : Trying to install a precompiled kernel module.
    [Message] Kernel Module : Precompiled kernel module version mismatched.
    [Message] Kernel Module : Found kernel module build environment, generating kernel module now.
    AMD kernel module generator version 2.1
    Error:
    kernel includes at /lib/modules/3.5.0-17-generic/build/include do not match current kernel.
    they are versioned as ""
    instead of "3.5.0-17-generic".
    you might need to adjust your symlinks:
    — /usr/include
    — /usr/src/linux
    [Error] Kernel Module : Failed to compile kernel module — please consult readme.
    [Reboot] Kernel Module : update-initramfs

  • https://www.blogger.com/profile/02762316643737159685 Роман Васильев

    хоть бы видеопособие сделали для чайников,что да как куда )))))))))

  • https://www.blogger.com/profile/01831991386449825632 Виктор

    Спасибо автору. Видео ATI HD4670 PCI-Express. Пробовал сделать по этой инструкции для Ubuntu 12.04.03 LTS — не вышло, ядро там было 3.8.0. Скачал старый релиз 12.04.02 LTS ядро 3.5.0-23 вышло почти все по инструкции. Отличие было в том что с version.h и созданием каталогов играться не пришлось. Перед выполнением инструкции на голой системе было выполнено sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases linux-headers-generic fakeroot. И еще по совету с https://launchpad.net/~makson96/+archive/fglrx "If you are using Ubuntu 12.04.2 make sure you got linux-headers-generic-lts-quantal package installed." доставил и это. А потом по инструкции. Все заработало — еще раз СПАСИБО!

  • https://www.blogger.com/profile/08247352864505913668 Matrixd

    Автор, добавь в гайд. Перед даунгредйом Xorg неплохо было бы посмотреть нужно ли вообще это делать:
    Xorg -version
    Если необходима работа еще и 32-х битной Opengl, а у вас x64 ось, то дополнительно выполняем:
    sudo mkdir /usr/lib32/modules/3.5.0-34-generic/

    sudo mkdir /usr/lib32/modules/3.5.0-34-generic/build

    sudo cp /usr/src/linux-headers-3.5.0-34-generic/include/linux/version.h /usr/lib32/modules/3.5.0-34-generic/build

    Где 3.5.0-34-generic == kernel version

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Спасибо, добавлю.

  • Анонимный

    Обновите пожалуйста пропатченные драйвера, ибо ссылка более не работает(

    • https://www.blogger.com/profile/03229427242413784356 Эдуард Кобылянец

      Сегодня вечером обновлю, на Ubuntu one было выложено. Хорошо, что напомнили.

    • Анонимный

      Спасибо что обновили ссылку). Пожалуйста если не затруднит выложите на "яндекс диск" или куда-либо еще, спасибо)

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Извиняюсь, забыл про них совсем. Если очень нужно было, надо было на почту написать, я бы Вам выслал сразу бы.

      Ссылку обновил, теперь можете скачать.

    • Анонимный

      Спасибо, выручили.

  • Анонимный

    Как версию xorg понизить? через репо макона96 не получается. выдается ошибка на стадии apt-get update

    W: Не удалось получить http://ppa.launchpad.net/makson96/fglrx/ubuntu/dists/trusty/main/source/Sources 404 Not Found
    W: Не удалось получить http://ppa.launchpad.net/makson96/fglrx/ubuntu/dists/trusty/main/binary-amd64/Packages 404 Not Found
    W: Не удалось получить http://ppa.launchpad.net/makson96/fglrx/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found
    E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.

    через Synaptic так же не получается (функция Пакет -> Установить версию неактивна)

  • https://www.blogger.com/profile/02005146393153687945 Zing Chan

    Здравствуйте, а есть ли способ редактировать (править) драйвер для новых версий ubuntu?Чтоб хотя бы запустился без каталиста