Установить последнюю версию Google Earth в Ubuntu 14.04 — 12.04

В данной статье расскажу о том, как установить программу Google Earth в Ubuntu.

1. Коротко о программe Google Earth.

Google Earth - это проект от компании Google, предоставляющий спутниковые снимки земной поверхности.
База фотографий постоянно обновляется.

Рассмотрим установку Google Earth на Ubuntu Linux.

2. Установка последней версии Google Earth в Ubuntu 12.04 - 13.10, 14.04

Откройте терминал и выполните следующие команды поочередно, в соответствии с вашей версией и архитектурой ОС Ubuntu:

Если у Вас Ubuntu 12.04.

Для 32 bit:

cd /tmp/

wget -O google-earth32.deb http://dl.google.com/dl/earth/client/current/google-earth-stable_current_i386.deb

sudo dpkg -i google-earth32.deb

sudo apt-get -f install

Для 64 bit:

cd /tmp/

wget -O google-earth64.deb http://dl.google.com/dl/earth/client/current/google-earth-stable_current_amd64.deb

sudo dpkg -i google-earth64.deb

sudo apt-get -f install

Если у Вас Ubuntu 13.10, 14.04. 

Для 32bit:
cd /tmp/

wget -O google-earth32.deb http://dl.google.com/dl/earth/client/current/google-earth-stable_current_i386.deb

sudo dpkg -i google-earth32.deb

sudo apt-get -f install

Для 64bit:

sudo apt-get install libc6-i386 libglib2.0-0:i386 libsm6:i386 libglu1-mesa:i386 libgl1-mesa-glx:i386 libxext6:i386 libxrender1:i386 libx11-6:i386 libfontconfig1:i386 lsb-core

sudo apt-get -f install

cd /tmp/

wget -O google-earth64.deb http://dl.google.com/dl/earth/client/current/google-earth-stable_current_i386.deb

sudo dpkg -i google-earth64.deb

sudo apt-get -f install

Если у вас шрифты выглядят ужасно, то советую установить следующий пакет шрифтов, в терминале выполните следующую команду:sudo apt-get install msttcorefonts

Вот и всё.

  • http://ads707.ya.ru/ ads707

    У него в зависимостях rpm, alien, rpm2cpio — это нормально для дебовского пакета?

  • https://www.blogger.com/profile/18316937580952831335 Владислав Магада

    На сайте гугла есть все и так) и для дебиана и для других) после ваших статей об терминале пользователь сам может установить все без особых сложностей)

  • Анонимный

    в данной программе вообще руский шрифт не отображался, решал проблему так
    sudo apt-get install xfonts-cyrillic

    • https://www.blogger.com/profile/09313961481970282400 Яков Гусев

      Не помагает (

  • https://www.blogger.com/profile/05899321006655363019 Serge

    В Kubuntu 13.10-64 не ставится, требует ia32-libs, а ее нет в репозитории

  • https://www.blogger.com/profile/17644227721625409424 danwerspb

    В 14,04 не может взять нужную зависимость.

    dp@sev-lucky:/tmp$ sudo dpkg -i google-earth64.deb
    Выбор ранее не выбранного пакета google-earth-stable.
    (Чтение базы данных … на данный момент установлено 236394 файла и каталога.)
    Preparing to unpack google-earth64.deb …
    Unpacking google-earth-stable (7.1.2.2041-r0) …
    dpkg: зависимости пакетов не позволяют настроить пакет google-earth-stable:
    google-earth-stable зависит от ia32-libs, однако:
    Пакет ia32-libs не установлен.

    dpkg: error processing package google-earth-stable (—install):
    проблемы зависимостей — оставляем не настроенным
    Processing triggers for man-db (2.6.6-1) …
    Processing triggers for menu (2.1.46ubuntu1) …
    Processing triggers for gnome-menus (3.8.1-0ubuntu2) …
    Processing triggers for desktop-file-utils (0.22-1ubuntu1) …
    Processing triggers for bamfdaemon (0.5.1+14.04.20131125-0ubuntu2) …
    Rebuilding /usr/share/applications/bamf-2.index…
    Processing triggers for mime-support (3.54ubuntu1) …
    При обработке следующих пакетов произошли ошибки:
    google-earth-stable
    dp@sev-lucky:/tmp$ sudo apt-get install ia32-libs
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Package ia32-libs is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:
    lib32z1 lib32ncurses5 lib32bz2-1.0

    E: Package 'ia32-libs' has no installation candidate
    dp@sev-lucky:/tmp$

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Прочитайте вот эту статью: http://www.linuxrussia.com/2014/02/32-libs-ubuntu.html

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      sudo dpkg —add-architecture i386

      sudo apt-get update

      sudo dpkg -i google-earth64.deb

  • https://www.blogger.com/profile/05661834297113897492 reb

    как запустить установленный google chrome stable в ubuntu 12.04 с терминала?

  • Анонимный

    Wow! Теперь гугля еартх в репозитории!
    sudo apt-get install google-earth-stable

    • Анонимный

      А в каких?
      sudo apt-get install google-earth-stable
      Чтение списков пакетов… Готово
      Построение дерева зависимостей
      Чтение информации о состоянии… Готово
      E: Не удалось найти пакет google-earth-stable

    • Анонимный
  • Анонимный

    Фотографии не отображаются . Белый фон и описание фото. (ubuntu 14.04 64 bit)

    • https://www.blogger.com/profile/00865845114198842309 Edward Kobylyanets

      Есть такой баг на Ubuntu 14.04 64 бита, не нашел решения этому. Видимо ждать исправления от разработчиков…

  • Анонимный

    что делает команда sudo apt-get -f install?

  • Анонимный

    Исправляет пакеты с ошибками

  • https://www.blogger.com/profile/16862917692209153641 Игорь Иванов

    В panapamio, фотографии не видны

  • https://www.blogger.com/profile/13614844782665283668 AVV

    Фотографии не отображаются в Linux и в винде, в гугл земля и в гугл земля про. Это не из-за системы. Глюк самого гугла.