Установка Google Chrome и Opera в Ubuntu 14.04 - 12.04

Вот, уже на протяжении многих лет по умолчанию в Ubuntu установлен один браузер - Mozilla Firefox. У каждого есть свои предпочтения и многим больше нравятся другие топ-браузеры, такие как Google Chrome и Opera. И в данной статье я расскажу, как их установить в Ubuntu.

Данная статья была разбита на две отдельные статьи.

Чтобы прочитать про установку Google Chrome в Ubuntu, пройдите по следующей ссылке:
 
Чтобы прочитать про установку Opera в Ubuntu, пройдите по следующей ссылке:

Поделиться:

Если у Вас возникли вопросы.

Приглашаю задавать их на сервисе вопросов и ответов: Ask LinuxRussia.com.
Там Ваши вопросы не потеряются и Вы быстрее получите ответ, в отличие от комментариев.

51 коммент. :

  1. Анонимный5 мая 2013 г., 23:31

    Как убрать репозиторий оперы. При установке вроде ключ не был найден. Сам браузер поставил с другого ппа. Но теперь при обновление системы и в синаптике вылазит.
    W: Не удалось получить http://deb.opera.com/opera/dists/lenny/non-free/binary-i386/Packages 404 Not Found

    E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.

    ОтветитьУдалить
    Ответы
    1. sudo rm /etc/apt/sources.list.d/opera.list

      sudo apt-get update

      Удалить
    2. Проверил, действительно ключ не получает. Спасибо, что сказали. Статью исправлю.

      Удалить
    3. Анонимный6 мая 2013 г., 0:45

      Вам спасибо, очень хороший сайт.

      Удалить
  2. Думаю хром ставить лучше вот так:

    sudo wget https://dl.google.com/linux/direct/google-chrome-stable_current_i386.deb
    sudo dpkg -i google-chrome-stable_current_i386.deb
    sudo rm google-chrome-stable_current_i386.deb

    В этом случае не будет создаваться дублирующая строчка в списке репозиториев.

    Если необходимо 64 бита то просто переименуйте скачиваемый пакет в google-chrome-stable_current_amd64.deb

    ОтветитьУдалить
    Ответы
    1. Она и сейчас не создается, дублирующая строчка, спасибо за подсказку от Анонима.

      И лучше ставить из репозитория, так будет версия обновляться хрома при обновлении системы.

      Удалить
    2. Репозиторий подключается автоматически при установки .deb и все будет обновляться.

      Удалить
  3. Анонимный29 июня 2013 г., 9:30

    А вот, что выдает при обновлении списка пакетов после добавления репозитория хрома:
    W: Ошибка GPG: http://dl.google.com stable Release: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY A040830F7FAC5991

    ОтветитьУдалить
    Ответы
    1. Сейчас проверил, все работает. Вы первый пункт пропустили значит: wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

      Удалить
  4. Анонимный16 июля 2013 г., 7:44

    При попытке установить libudev0 for 32bit выдает Ошибка: Неразрешимая зависимость: libc6 (>= 2.17). Не в этом ли причина частых крахов flash?

    ОтветитьУдалить
    Ответы
    1. http://packages.ubuntu.com/raring/libc6
      Вот недостающий файл.

      Сейчас Гугл хром должен устанавливаться и работать без установки libudev0.

      Удалить
  5. Анонимный21 июля 2013 г., 13:18

    Админ, а вы не знаете как сделать глобальное меню в Opera? Ubuntu 12.04

    ОтветитьУдалить
    Ответы
    1. Насколько мне известно, такого способа нет.

      Удалить
  6. Анонимный22 июля 2013 г., 18:45

    После добавления репозитория Оперы и обновления выдает ошибку
    W: Ошибка GPG: http://www.openprinting.org lsb3.1 Release: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY 7A4B44C2D2A2203E

    ОтветитьУдалить
    Ответы
    1. sudo sh -c 'wget -O - http://deb.opera.com/archive.key | apt-key add -'

      Вот эту команду выполните

      Удалить
    2. Выполнил команду
      sudo sh -c 'wget -O - http://deb.opera.com/archive.key | apt-key add -'
      после обновления sudo apt-get update ошибка
      W: Ошибка GPG: http://www.openprinting.org lsb3.1 Release: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY 7A4B44C2D2A2203E
      Перед этим делаел, как у вас написано.
      1. Загружаем ключ репозитория:
      2. Добавляем, непосредственно, сам репозиторий:
      3. Затем обновляем сведения о пакетах:
      У меня установлена Ubuntu 13.04 х64

      Удалить
    3. sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 7A4B44C2D2A2203E


      затем апдейт

      Удалить
  7. Не получилось. Установил вот так -
    echo "deb http://deb.opera.com/opera/ stable non-free" | sudo tee -a /etc/apt/sources.list
    sudo wget -O - http://deb.opera.com/archive.key | sudo apt-key add -
    sudo apt-get update && sudo apt-get install opera
    У вас ошибка при установке ключа, последний символ после тире лишний.
    Как устранить ошибки -
    W: Ошибка GPG: http://www.openprinting.org lsb3.1 Release: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY 7A4B44C2D2A2203E
    W: Duplicate sources.list entry http://deb.opera.com/opera/ stable/non-free amd64 Packages (/var/lib/apt/lists/deb.opera.com_opera_dists_stable_non-free_binary-amd64_Packages)
    W: Duplicate sources.list entry http://deb.opera.com/opera/ stable/non-free i386 Packages (/var/lib/apt/lists/deb.opera.com_opera_dists_stable_non-free_binary-i386_Packages)? Если вам не трудно.

    ОтветитьУдалить
    Ответы
    1. sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 7A4B44C2D2A2203E


      затем апдейт

      Написал же выше

      Удалить
  8. W: Ошибка GPG: http://www.openprinting.org lsb3.1 Release: Следующие подписи неверные: BADSIG 7A4B44C2D2A2203E OpenPrinting (OpenPrinting Test Key)
    W: Duplicate sources.list entry http://deb.opera.com/opera/ stable/non-free amd64 Packages (/var/lib/apt/lists/deb.opera.com_opera_dists_stable_non-free_binary-amd64_Packages)
    W: Duplicate sources.list entry http://deb.opera.com/opera/ stable/non-free i386 Packages (/var/lib/apt/lists/deb.opera.com_opera_dists_stable_non-free_binary-i386_Packages)
    Это после апдейта.
    Дело в том, что я не нахожу в менеджере пакетов lsb3.1 Release, чтобы его отключить, там есть только версия 4

    ОтветитьУдалить
    Ответы
    1. Введите эту команду
      sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys

      В конце вставьте ваш номер ключа, то есть 7A4B44C2D2A2203E

      Получается
      sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 7A4B44C2D2A2203E

      Вот, потом sudo apt-get update
      Про дублирующие репозитории советую почитать статью:

      http://www.linuxrussia.com/2013/04/ubuntu.html

      Удалить
    2. И, кстати, в статье все команды правильные, ваш ключ не относится к репозиторию Оперы. В командах нет лишних знаков. :)

      Удалить
    3. Заходим в менеджер обновлений, настройки. Откроются источники приложений:
      Вот на этой вкладке можно отключить дублирующие репозитории:
      [im]http://2.bp.blogspot.com/-Bo5GA-Zs4h8/Ue68JcSUKnI/AAAAAAAACG0/2Upat7P1XAc/s640/%D0%98%D1%81%D1%82%D0%BE%D1%87%D0%BD%D0%B8%D0%BA%D0%B8+%D0%BF%D1%80%D0%B8%D0%BB%D0%BE%D0%B6%D0%B5%D0%BD%D0%B8%D0%B9_047.png[/im]
      Вот здесь убрать ключи:
      [im]http://4.bp.blogspot.com/-myDjR7HJxgQ/Ue68OGACt8I/AAAAAAAACG8/VeefuYTd0Nk/s640/%D0%98%D1%81%D1%82%D0%BE%D1%87%D0%BD%D0%B8%D0%BA%D0%B8+%D0%BF%D1%80%D0%B8%D0%BB%D0%BE%D0%B6%D0%B5%D0%BD%D0%B8%D0%B9_046.png[/im]

      Удалить
    4. Большое спасибо за информацию! Извините, если задавал глупые вопросы.
      Это мои первые шаги в Линукс. С ошибками, думаю разберусь.:-)

      Удалить
    5. Пожалуйста, все когда-то начинали с таких вопросов. Нет в этом ничего такого.

      Удалить
  9. Хром то установился, а вот не подскажете ли как в нем шрифты заменить? Очень проблематично читать все. :(

    ОтветитьУдалить
    Ответы
    1. Настройки > Настройки > Показать дополнительные настройки (внизу) > Веб контент > Настроить шрифты

      Удалить
  10. Моё почтение! Саму Оперу 12.16.1860 i386 устанавливал с .deb файла (http://yadi.sk/d/ZZnqsGx8A6jKz). Работает отлично чем меня как сторонника этого браузера несказанно радует! И еще кому интересно...многие заметили какой ущербный и неприглядный вид имеет в последние года полтора этот браузер. Тот скин, что идет по умолчанию ну никак не привлекает и не способствует комфортной работе...а установка предлагаемых псевдо-скинов то это просто смена фоновой картинки без реального изменения значков, их дизайна и поведения а также самого вида программы! Поэтому имея довольно большой опыт работы с Оперой в среде Виндовс осмелюсь предложить и пользователям Ubuntu альтернативный способ изменения скина коим пользовался раньше. Суть вкратце такова...нужно произвести копирование уже готовых скинов Оперы с расширением .zip в папку установки Оперы в Ubuntu а затем как обычно в программе выбрать понравившийся скин. Вот файлы скинов для добавления (http://yadi.sk/d/V48vpSkqA6gAX) Саму замену производил в Midnight Commander (http://s019.radikal.ru/i611/1309/0b/52316194ec97.png) , так мне удобнее.....привык тотал Командеру в Виндовс...Вот так выглядит моя Опера в Ubuntu http://s019.radikal.ru/i603/1309/47/42bca02b09d1.png
    Всем добра!

    ОтветитьУдалить
    Ответы
    1. Спасибо, добавлю в статью ваши картинки и ссылку на скачивание скина.

      Удалить
  11. Подскажите, пожалуйста.
    Устанавливаю Chrome на Kubuntu 13.04 описанным в статье способом. Результат команды "sudo apt-get install google-chrome-stable":

    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
    или же используете нестабильную версию дистрибутива, где запрошенные вами
    пакеты ещё не созданы или были удалены из Incoming.
    Следующая информация, возможно, поможет вам:

    Пакеты, имеющие неудовлетворённые зависимости:
    google-chrome-stable : Зависит: lib32gcc1 (>= 1:4.1.1) но он не может быть установлен
    Зависит: lib32stdc++6 (>= 4.6) но он не может быть установлен
    Зависит: libc6-i386 (>= 2.11) но он не может быть установлен
    E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

    Synaptic не показывает указанные недостающие пакеты, через него установить не получается.
    Что можно предпринять?

    ОтветитьУдалить
    Ответы
    1. Скачать подготовленные пустые пакеты:
      wget https://dl.dropboxusercontent.com/u/85403877/ubu13-chrome-fix/lib32gcc1_4.7.3-1ubuntu1_all.deb

      wget https://dl.dropboxusercontent.com/u/85403877/ubu13-chrome-fix/lib32stdc%2B%2B6_4.7.3-1ubuntu1_all.deb

      wget https://dl.dropboxusercontent.com/u/85403877/ubu13-chrome-fix/libc6-i386_2.17-0ubuntu5_all.deb

      Установить их следующей командой:
      sudo dpkg -i lib32gcc1_4.7.3-1ubuntu1_all.deb lib32stdc++6_4.7.3-1ubuntu1_all.deb libc6-i386_2.17-0ubuntu5_all.deb


      После этого пробовать устанавливать гугл хром.
      на 13.04 unstable должен ставиться без проблем. А если стабильную, то вышепреведенный мной способ.

      Удалить
    2. Аллилуйя :)
      Эдвард, спасибо! Все установилось и заработало на ура! :)

      Удалить
    3. Рад, что помогло, добавлю в статью этот способ. Может еще поможет кому нибудь.

      Удалить
  12. Не понимаю почему в тут паритесь с командами в терминале а не откроете Убунту софт центр где Хром есть и не установите его нажатием кнопки. Опера тоже элементарно устанавливается скачкой готового файла для Убунту с её страницы.

    ОтветитьУдалить
    Ответы
    1. Пока ты зайдешь, пока найдешь, пока скачаешь, откроешь... Бее. С терминалом намного удобнее работать. Тут 2-4 команды ввел, и все.

      Удалить
    2. Надо и такое описать в статье, чтобы не возникало таких комментариев. Люди то разные, кто-то очень боится консоли...

      Удалить
  13. Спасибо за помощь, отличный сайт много полезного и нужного. Сделал проще на xubuntu 13.10 скачал .deb -пакет хром браузера и запустил в установщике пакетов gdebi, перед установкой установил библиотеки на всякий случай думал делать сначала по инструкции, обошёлся без терминала. Хром работает отлично в отличии от хромиума с которым были проблемы при отображении флешей, сейчас все отлично.

    ОтветитьУдалить
  14. ничего не получилось

    ОтветитьУдалить
    Ответы
    1. В смысле ничего? какие были проблемы? Что писало в терминале?

      Удалить
  15. Инструкция не рабочая. Выдает ошибку.

    ОтветитьУдалить
  16. А почему нельзя скачать .deb пакет c http://opera.com/ и запустить его двойным кликом? Опера ставится, репозиторий подхватывается. Зачем столько телодвижений в терминале?

    Я -- "чайник". Гоняю Mint Petra на виртуалке. Не бейте ногами, пожалуйста! :)

    ОтветитьУдалить
    Ответы
    1. Да, можно и так.
      Надо это добавить, как другой способ установки, для тех, кому не нравится терминалом пользоваться.

      Удалить
  17. Анонимный17 мая 2014 г., 13:43

    СПС!!!!!!!!!!!!!

    ОтветитьУдалить
  18. Анонимный23 мая 2014 г., 2:13

    Пользуюсь Оперой с незапамятных времен. Как и многие, познакомился с ней, работая еще в Виндах.
    Линь-версию Оперы ( .deb) поставил с помощью gdebi (ПКМ по скачанному дистрибутиву, "Открыть с помощью"). Никаких проблем с Оперой не было и, к счастью, нету, в отличие от последних ее Виндёвых версий ;)

    ОтветитьУдалить
  19. E: Неизвестный тип «http://ppa.launchpad.net/alexx2000/doublecmd/ubuntu» в строке 1 в списке источников /etc/apt/sources.list.d/additional-repositories.list
    E: Не читается перечень источников.
    Помогите исправить

    ОтветитьУдалить
    Ответы
    1. sudo gedit /etc/apt/sources.list.d/additional-repositories.list

      Закомментировать строчки с ppa.launchpad.net/alexx2000/doublecmd/ubuntu,
      то есть поставить # в начале каждой строчке. Сохранить файл.

      Запусть sudo apt-get update - ошибки не будет.

      Удалить
  20. 100%[++++++++++++++++++++++++==============>] 47 314 768 53,3K/s в 33m 56s +

    2014-10-22 20:05:29 (8,51 KB/s) - «google-chrome-stable_current_i386.deb.1» saved [47314768/47314768]

    вот что дальше делать после этого

    ОтветитьУдалить
  21. помогите, не могу установить хром-браузер((( в ubuntu 14
    система сообщает : You are recommended to install the software from the channel instead.
    вооще не пойму - что она имеет в виду(((
    я - чайник, только вчера установила Ubuntu вместо windows 8.1

    ОтветитьУдалить